lunedì 15 febbraio 2010

La variabile PICKFIRST e l'editazione delle entità

Casualmente, a causa di un'assistenza, sono venuto a conoscenza di uno strano comportamento di AutoCAD. Come ben saprete AutoCAD sin dalle prime versioni ha sempre permesso l'editing delle entità in due modi: prima si avvia il comando poi si seleziona l'oggetto da modificare, oppure prima si seleziona poi si avvia il comando. Questo comportamento, denominato in AutoCAD "selezione nome/verbo", è gestito dalla variabile PICKFIRST.
Ma ora vengo al dunque: se la variabile è settata a 0 (zero) il menù contestuale di editazione degli oggetti non presenta la voce Proprietà


ma basta settare questa a 1, o agire da apposito pannello delle opzioni (scheda Selezione, sezione Modalità di selezione)



e la voce Proprietà magicamente ricompare. Non ci crederete ma se la variabile è disattivata non funziona nemmeno la modifica tramite doppio-click!


17 commenti:

  1. GRAZIE dal profondo del cuore! *_*
    stavo impazzendo per capire come mai non funzionasse più il doppio click!! :(

    RispondiElimina
  2. stavo per lanciare il pc dalla finestra! :-) grazie..

    RispondiElimina
  3. nel mio pc il tasto canc funziona ad intermittenza.. quando non funziona però mi lampeggia il puntatore in basso nello schermo davanti alla voce, comando, che mi fa intuire che il tasto funzioni e che il pc riceve il segnale del tasto...
    cosa diamine può essere?

    RispondiElimina
  4. Mai sentito nulla di simile. Non saprei, mi dispiace.

    RispondiElimina
  5. Questo commento è stato eliminato da un amministratore del blog.

    RispondiElimina
  6. Grazie mille! sono giorni che impazzisco per questo problema

    RispondiElimina
  7. ho una domanda se ti va di rispondere, come faccio ad aggiungere copia taglia cancella ecc alla tendina del tasto destro? inoltre ho seguito il tuo consiglio ma proprietà non è ricomparsa. ti ringrazio molto

    RispondiElimina
  8. Segui questi semplici passaggi:
    https://knowledge.autodesk.com/support/autocad/troubleshooting/caas/sfdcarticles/sfdcarticles/Modifying-right-click-shortcut-menu.html#mtc-italian

    RispondiElimina
  9. Grazie infinite! Ho perso la funzione in seguito ad un crack di sistema. Ho passato le ultime 2 ore cercando di sistemare il problema, poi è stato sufficiente "Googleare" il problema ed è apparsa magicamente la pagina del blog.

    RispondiElimina
  10. buongiorno
    da qualche giorno anche io ho un problema con la selezione oggetti e comando successivo, ma con delle stranezze...: la variabile PICKFIRST è impostata a 1 (anche PICKADD=1), infatti se seleziono l'oggetto e poi SCRIVO il comando funziona, ma se faccio la selezione e CLICCO sul comando NON funziona (perde la selezione). Inoltre il doppio click di un singolo oggetto fa aprire la finestra delle proprietà rapide, MA se seleziono uno o più oggetti ed apro la finestra delle proprietà la selezione viene persa ! Anche il doppio click su un testo per modificarlo non funziona più...
    qualcuno mi sa aiutare?

    RispondiElimina
    Risposte
    1. Autocad Mechanical 2014.
      Probabilmente non ci combina niente ed è solo una coincidenza, ma mi sembra che il problema sia sorto dopo aver caricato un file lisp (per esplodere in una volta sola blocchi contenenti tanti blocchi nidificati). Possibile? Cmq il lisp l'ho tolto (col comando APPLOAD) ma il problema è rimasto.

      Elimina
  11. ho risolto!!
    sono andato a vedere il lisp di cui ho parlato prima ed ho visto che impostava la variabile QAFLAGS=1 (variabile che controlla i "return"), poi esplodeva i blocchi nidificati ma alla fine del lisp non riportava a 0 la variabile QAFLAGS (o meglio...lo faceva ma avevo modificato malamente io il file eliminando questa riga).
    Quindi ho semplicemente impostato QAFLAGS=0 e adesso funziona tutto.
    Grazie cmq per il rapido l'interessamento.

    RispondiElimina
  12. Da una settimana quando clikko sul comando delle barra ad esempio il taglia devo attendere qualche decimo di secondo sul comando stesso se non non me lo prede ....e se faccio troppo velocemente devo noiosamente ritornare a prendere il comando rendendo poco fluido il lavoro qualcuno sa darmi una risposta ?' autcad2011 ma fa lo stesso problema sul 2004lt grazie 1000

    RispondiElimina